
Version 4.7 Hotfix 3

August 29, 2024

Fixed:

• The incorrect format of final auto scores in Windows with the Netherlands regional format. 

• [Experiment Page] [Tools] The malfunctioning formatting buttons in the Annotate field of the Tool 

Options section. 

• [Experiment Page] An error when opening a drop image with a newly created crystal mask. 

• [Experiment Page] [Tools] An error when resetting Image Tuning. 

• [Experiment Page] [Drop Submenu] An error when clicking the Harvesting button of a loading

drop image. 

• [Experiment Page] [Score Panel] The duplicated auto scoring data. 

• [Screen Experiment Wizard] The truncated Volume field in the Selected Screen(s) section. 

• [Screen Experiment Wizard] The unapplied customized protein drop and solution volumes. 

• [Screen Experiment Wizard] The uncreated experiments for non-default temperature.

• [Screen Experiment Wizard] The misaligned checkboxes in the Selected Incubation Temperature

section. 

Version 4.7 Hotfix 2

July 15, 2024

Fixed:

• [Tools Panel] The unapplied Image Tuning value from the Canvas to the Drop menu and vice

versa.

• The displayed Print Barcode button in the Explore menu although disabled from User

Preferences.

• [Settings] [Find Orphan Images Submenu] The unupdated Results section when performing

orphan image searches in another directory. 

• The undisplayed scores in the image section of an experiment report. 

• An error when logging in to a newly upgraded software version. 

• [Score Panel] An error when modifying the Auto Score Threshold section of the Filter tab. 

• The incorrect online help version link in the Help button. 

• [Image Management Task] The stuck progress bar in the Results tab when executing a task

without selecting a lightpath. 
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• [Image Management Task] [Results Tab] The undisplayed task preview in the result table when 

executing a deletion task. 

• [Experiment Page] The malfunctioning hotkeys when scoring images manually in the Drop, Well, 

or Compare menu. 

• [Experiment Page] The malfunctioning manual score removal feature using hotkey in the Drop, 

Well, or Compare menu. 

• [Experiment Page] The undisplayed tooltip when hovering over scores in the Drop, Well, or 

Compare menu. 

• The auto scoring inability to score visible images recognized as non visible images in some 

experiments. 

• The inconsistent Unscored Images Count value in the Auto Score Status dialog box. 

• The intermittent failure to save auto scores in the ROCK MAKER database. 

Version 4.7 Hotfix 1

June 3, 2024

Fixed:

• The malfunctioning arrows of the well button in the bottom bar preventing users from navigating

through wells in a newly created screen. 

• (User Interface) The unnecessary Finish button in the Batchload Experiments wizard and

lowercase Exit button. 

• (User Interface) The inconsistent text spacing in the Optimization Wizard. 

• (User Interface) The unnecessary BACK and OPTIMIZE buttons in the last section of the 

Optimization Wizard. 

• The ROCK MAKER version 4’s log format to follow the log format in ROCK MAKER desktop

software. 

• The unapplied image tuning to other menus on the experiment page. 

• The unnecessary scroll bar in the Layers Design panel when adding ingredients to a grid, protein,

or fragment layer. 

• The unaligned header and content in the Action column of the Search All window. 

• The unhighlighted Edit and Delete buttons in the Standard Ingredient section when hovered

over during a protein formulation creation. 

• An irrelevant notification after deleting an ingredient type in the Protein Formulation tab. 

• (ROCK MAKER Installation) The unterminated Maintenance Mode Service in Task Manager after

exiting ROCK MAKER version 4 installation wizard. 

• The disappearing image tools created when using Slide Show in the Compare or Well menu

upon exiting Slide Show. 
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• A failure to paste default screens into a screen folder. 

• The undisplayed drop information in the Plate Drops section of the Plate Types submenu after 

editing a plate specification. 

• The undisplayed project name in the Project field of a generated synchrotron trip report.

• An error when importing an XML screen file with resolved conflicting ingredients. 

• The missing plus icon between the second and third volume information in the Drop field of an 

ingredient report.

• (Searches) The unaligned header and content of the search result table in the Result menu. 

• (ROCK MAKER-NT8 Integration) The undisplayed newly created plate type in the NT8: Intermediate

Plate dropdown in the Dispensing Properties submenu. 

• The failure to cut, copy, or paste a search and filter file in the Searches node. 

• (ROCK MAKER Installation) The blank space in the ROCK MAKER installation wizard. 

• (ROCK MAKER Installation) The unloaded configuration file in the Configuration File field of the

ROCK MAKER installation wizard. 

• (ROCK MAKER Installation) The enabled Login and Password fields after selecting Windows

Authentication in the Authentication field of the ROCK MAKER installation wizard. 

• (Searches) The displayed plate drop in the Design submenu of the Canvas menu to follow the

plate type definition. 

• (ROCK MAKER Installation) The irrelevant error notification during the ROCK MAKER installation. 

• The displayed Rock Maker Lite option when signing in to a ROCK MAKER without a ROCK MAKER

Lite license. 

• (Searches) The undisplayed manual scores in the Image submenu of the Canvas menu. 

• (ROCK MAKER-ROCK IMAGER Integration) The failure to differentiate the uppercase and

lowercase in an experiment barcode scanning. 

• The undeleted 0 value in the Older Than field of the Image Management Task tab. 

• The displayed deleted images in the Image submenu of the Canvas menu and the Loading

Image state of the deleted images in the Drop menu. 

• The unspecified auto scoring model’s name in the auto scoring log file. 

• (Explore Menu) The unavailable scroll bar in the Analyze option of the More button. 

• (Explore Menu) The unavailable arrow buttons in Searches and Projects of the Analyze option. 

• (ROCK MAKER-ROCK IMAGER Integration) Unmarked expired plates when skipping all imaging

schedules. 

• The unhighlighted Delete buttons in the Group panel within the Layers Design panel when

hovered over. 

• The unapplied inherited scores in an experiment. 

• The database backup failure when upgrading from ROCK MAKER version 4.6 to ROCK MAKER

version 4.7. 

Copyright © 2024 FORMULATRIX. All Rights Reserved. www.formulatrix.com

R
O

C
K

 M
A

K
E

R
 R

e
le

as
e

 N
o

te
s

3



• The malfunctioning Lock radio button in the Tools panel while working with Point of Interest (POI). 

• The undisplayed recently opened fragment screen in the Recently Opened section of the ROCK 

MAKER main page. 

• Incomplete information about a fragment screen condition in the side panel of the Explore menu. 

• The disabled Image Tools buttons in the Tools panel when switching from the Drop to Well menu. 

• The unadjusted image areas in the Compare menu of a search and filter file. 

• The enabled Force Unlock option in the More button when selecting an unlocked item. 

• The undisplayed conflicting ingredient icon of the missing stock ingredient in the Conflict 

Ingredients section of the Import Ingredients Options dialog box. 

• An error when zooming in on the Canvas menu after importing an inspection package from the 

desktop software. 

• (Settings Menu) The table width in the User and Group tab of the Administrator submenu and

the displayed ROCK MAKER Lite column in the User section for ROCK MAKER without a ROCK

MAKER Lite license. 

• The undisplayed expired experiment plate icon on an imaged experiment. 

• An irrelevant notification when deleting an in-use experiment plate. 

• (Searches) A performance issue when hovering on tooltips, scrolling results, and switching

between submenus in the Canvas menu. 

• An inaccurate zooming in the Canvas menu of a search and filter file. 

• The malfunctioning hotkeys when scoring images in the Drop menu. 

• The inconsistent Auto Score Next Well status when moving to other menus. 

• (Drop Menu) The score applied to both drops when scoring only one drop. 

• The mirrored mouse pointer in the Well menu. 

• The randomly selected well when clicking on the Canvas menu’s blank space. 

• The malfunctioning copy-paste feature in protein formulation. 

• The failure to re-open a recently closed protein formulation from the Explore menu or the 

Recently Opened section on the ROCK MAKER main page. 

• The system printing a folder name instead of a project name. 

Version 4.7 BETA

May 6, 2024

Added:

• The Searches menu to find items based on particular criteria. 

• (Administrator only) The Image Management Task tab to the Imaging submenu of the Setup 

menu. 

• The Import DoE feature to import ingredients during a grid layer creation. 

• Fragment screen and fragment layer features to the experiment design. 
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• (Administrator only) The Find Orphan Images submenu to the Settings menu. 

• The Rotate Canvas feature to the experiment design. 

• (Administrator only) The Dispensing Properties submenu to the Setup menu. 

• ROCK MAKER Lite, the upgraded version of ROCK MAKER Web. 

• The Screen Repair feature to the experiment design. 

• The ROCK MAKER Version 4 auto scoring functionality, allowing users to work with auto scoring, 

send images for retraining, and dispute auto score without relying on ROCK MAKER Version 3. 

• A keyboard shortcut for multiple-item selection. 

• ROCK MAKER Version 4 - ROCK IMAGER Version 3 integration, enabling imaging features. 

Improved:

• Software behavior by adding a version mismatch notification upon login, ensuring database and

application compatibility. 

Fixed:

• Malfunctioning simultaneous manual scoring when scoring multiple drop images. 

• Inconsistent font size in the Single Drop Report Options dialog box. 

• The failure to update well and layer colors from the User Preferences submenu. 

• An unnecessary prompt when switching to another menu during a screen creation. 

• An incorrect canvas display when generating an experiment report with design report

information. 

• The reduced scribble size when scribbling in the Drop and Compare menus. 

• The displayed unimaged wells in the Slide Show window. 

• The failure to apply default incubation and setup temperature values set in User Preferences to a

new experiment. 

• The undisplayed notification when printing an ingredient label from the Ingredients submenu of

the Setup menu. 

• The different plates used in an optimization experiment and the original experiment. 

• The undisplayed warning message when updating a default non-buffer ingredient stock. 

• Undisplayed multiple scores when generating a score report. 

• Undisplayed image tools added to drops from the Slide Show window after closing it. 

• The missing information in the synchrotron trip report. 

• The unhighlighted High pH field in the Standard Ingredient section after selecting a Low PH 

during a protein formulation creation. 

• Unaligned fields in the Standard Ingredient section in a protein formulation tab. 

• An unnecessary error message when optimizing an experiment. 

• An error when optimizing selected wells from one column into a grid layer. 
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• (Screen Experiment Page) The undisplayed selected screen lot in the Design submenu of the 

Canvas menu if it was other than Lot 0. 

• The undisplayed imported ingredient concentration in the Ingredients section during a protein 

formulation creation if it was less than 1mM. 

• The accessible Image Now feature in ROCK MAKER Design Edition. 

• The accessible Imaging and Crystal Container submenus in the Setup menu in ROCK MAKER 

Design Edition.

• The insufficient information displayed by the CHECK UPDATE button in the Licensing submenu. 

• The unreset manual leveling values in the Image Tuning section upon discarding changes. 

• The undisplayed Absolute Time in the Navigator panel. 

• The undisplayed screen name in the Ingredients submenu of the Canvas menu. 

• The crashing system when switching from the Canvas menu to the Well menu on the experiment

page. 

• An error when navigating through wells in an inspection with numerous capture profiles. 
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